镜像站点 · 本页由第三方 GitHub 只读镜像提供,非 GitHub 官方站点,不接受任何登录或凭据输入。前往 github.com
Skip to content

Dependency specification missing for python3.14 #1165

Open

Description

@giochanturia

There is no case defined for numpy using python3.14 in pyproject.toml. As a result, installing packages that depend on opencv-python and a newer version of numpy does not work as expected and causes conflicts between numpy versions.

"numpy==2.1.3; python_version=='3.13'",

Activity

  1. lucalista commented on Jan 16, 2026

    @lucalista

    I also reported an issue related to a problematic numpy version (#1182) that was fixed with a manual upgrade of numpy version.

  2. MDSALMANSHAMS commented on Aug 17, 2026

    @MDSALMANSHAMS
    Contributor

    This one, #1155 and #1160 are all the same root cause, and it looks resolved since 4.13.0.90.

    The opencv wheel was never the problem on 3.14 — the wheels are cp37-abi3, so a 3.14 interpreter picks them up fine (both logs in #1155/#1160 show opencv_python-4.12.0.88-cp37-abi3-win_amd64.whl downloading successfully). What failed was the numpy requirement it pulled in. 4.12.0.88 capped it:

    4.12.0.88   numpy<2.0; python_version < "3.9"
                numpy<2.3.0,>=2; python_version >= "3.9"     <- the cap
    

    On 3.14 that cap resolves to numpy 2.2.6, which has no cp314 wheel, so pip fell back to building numpy from source — which is exactly the numpy-2.2.6.tar.gz → Preparing metadata (pyproject.toml) ... error both reporters hit.

    The cap is gone from 4.13.0.90 onward (checked the PyPI JSON metadata for each release):

    4.13.0.90   numpy>=2; python_version >= "3.9"
    4.13.0.92   numpy>=2; python_version >= "3.9"
    4.14.0.94   numpy>=2; python_version >= "3.9"
    5.0.0.93    numpy>=2; python_version >= "3.9"
    

    So pip on 3.14 now resolves to a numpy that actually ships cp314 wheels, and no source build is attempted.

    For the specific ask in this issue — a python_version case for 3.14 in the build requirements — pyproject.toml on 4.x now has one:

    "numpy==2.1.3; python_version=='3.13'",
    "numpy==2.3.2; python_version=='3.14'",

    @asmorkalov this looks safe to close, along with #1155 and #1160, unless someone can still reproduce it on 4.14.0.94 or 5.0.0.93.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions