镜像站点 · 本页由第三方 GitHub 只读镜像提供,非 GitHub 官方站点,不接受任何登录或凭据输入。前往 github.com
Skip to content

Update the minimal version of node/npm used in the repo #7426

Closed

Description

npm changed the way they handled dependencies in 6.6, and having contributors on npm versions on both sides of it causes dev: true, optional: true clutter in package-lock.json. We can update to anything below npm 6.11 because it breaks webpack (see https://github.com/microsoft/vscode-python/issues/7197).

According to https://nodejs.org/en/download/releases/ we can probably update the .nvmrc in the project to Node.js 10.16.3, which is an LTS version that supports npm 6.9.0.

Activity

  1. added a commit that references this issue on Sep 17, 2019
    25d6a84
  2. kimadeline commented on May 5, 2020

    @kimadeline
    Author

    We're now at 12.4:

    v12.4.0

  3. ghost removed on May 5, 2020
  4. locked as resolved and limited conversation to collaborators on May 20, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    debtCode quality issues

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions