The `setup.py` file should be updated to require `proto-plus` >= 1.25 for `python_version >=3.13` due to https://github.com/googleapis/proto-plus-python/issues/490 See release notes here: https://github.com/googleapis/proto-plus-python/releases/tag/v1.25.0 Add `"proto-plus >= 1.25.0, <2.0.0dev; python_version>='3.13'",` after the following line https://github.com/googleapis/python-spanner/blob/d3c646479bdc2ad96f68ed7d4703188dcdd76395/setup.py#L44 As an example, see https://github.com/googleapis/python-api-core/pull/740
Activity
chalmerlowe commentedon Mar 2, 2026
This issue was moved from the following repo as part of the monorepo migration: googleapis/python-spanner